北京荣瑞祥通网络科技有限公司
网络产品联系人:崔经理  15811507183
网络工程联系人:寸经理  13911765757

如何配置静态路由?

如何配置静态路由?这两个实例详解交换机与路由器的配置如何配置静态路由?无论是项目中交换机的静态路由配置,还是在公司网络中路由器的静态路由设置,都有非常多的应用,前段时间在弱电VIP群中也陆陆续续有不少朋友问到,本期我们一起来了解关于静态路由在交换机与路由器的配置。

本文分为三部分:

1、什么是静态的路由

2、实例讲解静态路由器在交换机项目中的应用

3、实例静态路由在公司网络中路由器的设置。


一、什么是静态路由?

一种路由的方式,路由项由手动配置,而非动态决定。与动态路由不同,静态路由是固定的,不会改变,即使网络状况已经改变或是重新被组态。一般来说,静态路由是由网络管理员逐项加入路由表,说白了,就是需要手动添加的,手动添加有什么好处呢?就是稳定可靠。

路由有什么作用呢?路由就是找路、选路的作用,那么如何选路?就要查表了,
实现这个作用的就是路由查询自己的路由表,路由表的学习就要用到静态或者动态路由。路由表的构成就是网络地址、子网掩码、下一跳地址(网关)。



二、交换机静态路由案例:实现不同网段之间互通

静态路由在交换机的有很多应用,可以解决实际项目中的很多组网问题,这里面我们举例来看下。

一、项目情况

如图3-120所示,属于不同网段的主机通过几台Switch相连,要求不配置动态路由协议,使不同网段的任意两台主机之间能够互通。


图片

配置不同网段通过静态路由实现互通组网图


二、配置思路

采用如下的思路配置不同网段通过静态路由实现互通:

1、创建VLAN并配置各接口所属VLAN,配置各VLANIF接口的IP地址,实现相邻设备网络互通。

2、在各主机上配置IP缺省网关,在各台Switch上配置IPv4静态路由或者静态缺省路由,实现不配置动态路由协议,使不同网段的任意两台主机之间能够互通。



三、配置步骤

1、配置各接口所属VLAN

# 配置交换机SwitchA。

图片

上面有注释,下面的SwitchB、SwitchB配置的意思与SwitchA一样,只是换了端口与vlan。

# 配置交换机SwitchB

<HUAWEI> system-view
[HUAWEI] sysname SwitchB

[SwitchB] vlan batch 10 20 40

[SwitchB] interface gigabitethernet 1/0/1

[SwitchB-GigabitEthernet1/0/2] port link-type trunk

[SwitchB-GigabitEthernet1/0/2] port trunk allow-pass vlan 10

[SwitchB-GigabitEthernet1/0/2] quit


[SwitchB] interface gigabitethernet1/0/2
[SwitchB-GigabitEthernet1/0/2] port link-type trunk
[SwitchB-GigabitEthernet1/0/2] port trunk allow-pass vlan 20

[SwitchB-GigabitEthernet1/0/2] quit


[SwitchB] interface gigabitethernet1/0/3
[SwitchB-GigabitEthernet1/0/3] port link-type access
[SwitchB-GigabitEthernet1/0/3] port default vlan 40
[SwitchB-GigabitEthernet1/0/3] quit


# 配置交换机SwitchC

<HUAWEI> system-view
[HUAWEI] sysname SwitchC
[SwitchC] vlan batch 20 50
[SwitchC] interface gigabitethernet1/0/1
[SwitchC-GigabitEthernet1/0/1] port link-type trunk
[SwitchC-GigabitEthernet1/0/1] port trunk allow-pass vlan 20
[SwitchC-GigabitEthernet1/0/1] quit
[SwitchC] interface gigabitethernet1/0/2
[SwitchC-GigabitEthernet1/0/2] port link-type access
[SwitchC-GigabitEthernet1/0/2] port default vlan 50
[SwitchC-GigabitEthernet1/0/2] quit


2、配置各VLANIF接口的IP地址

# 配置SwitchA的VLANIF接口的IP地址。

[SwitchA] interface vlanif 10
[SwitchA-Vlanif10] ip address 10.1.4.1 30

[SwitchA-Vlanif10] quit


[SwitchA] interface vlanif 30
[SwitchA-Vlanif30] ip address 10.1.1.1 24
[SwitchA-Vlanif30] quit

# 配置SwitchB的VLANIF接口的IP地址。

[SwitchB] interface vlanif 20
[SwitchB-Vlanif10] ip address 10.1.4.5 30

[SwitchB-Vlanif10] quit


[SwitchB] interface vlanif 40
[SwitchB-Vlanif30] ip address 10.1.2.1 24
[SwitchB-Vlanif30] quit

# 配置SwitchC的VLANIF接口的IP地址。

[SwitchC] interface vlanif 20
[SwitchC-Vlanif10] ip address 10.1.4.6 30

[SwitchC-Vlanif10] quit


[SwitchC] interface vlanif 50
[SwitchC-Vlanif30] ip address 10.1.3.1 24
[SwitchC-Vlanif30] quit


3、配置主机

配置主机PC1的缺省网关为10.1.1.1,主机PC2的缺省网关为10.1.2.1,主机PC3的缺省网关为10.1.3.1。


4、配置静态路由

# 在SwitchA配置IP缺省路由。

图片

# 在SwitchB配置两条IP静态路由。

图片

# 在SwitchC配置IP缺省路由。

图片


总结:

配置交换机主要是需要理清楚思路,这个静态路由案例中就是四个步骤:

1、创建vlan,并将vlan划入相应的端口

2、配置各VLANIF接口的IP地址

3、配置pc1、pc2、pc3的网关

4、配置静态路由


三、路由器中如何设置静态路由

上面弱电行业网举例了静态路由在网络项目中应用,交换机的配置,那么静态路由如何在路由器中设置,这个无论在我们项目中还是在公司中,也是经常需要用到。这里面我们再来举例详细了解。

一、项目情况:

在一个公司网络中,需要不仅可以通过无线路由器B连接外网,还可以通过无线路由器A来连接公司内网服务器在不修改本地连接的IP地址及网关情况下,公司电脑需要能够同时访问外网和内网服务器。配置实例如下图:

图片

在无线路由器中的详细配置过程如下

步骤1:

进入内网的路由器B管理界面,点击“路由功能”菜单,选择“静态路由表”,如下图:

图片


步骤2:

点击“添加新条目”按钮,在静态路由表中填写相应的参数。


图片

步骤3:

点击“保存”按钮后,在静态路由表中可以查看已有配置。

图片


步骤4:

在PC上访问内网服务器,检测静态路由条目是否生效。如果能访问,则说明静态路由配置成功。


在线客服
 
 
 
 
 工作时间
周一至周五 :9:00-18:00
周六至周日 :9:00-17:00
 联系方式
网络工程联系人:寸经理  13911765757
网络产品联系人:崔经理 15811507183
邮箱:rrxt@rrxt.com.cn